An Introduction to Solaris for Beginners by Brian Leonard. Presented at Oracle Tech Days, Hyderabad, India, March 2010.
- Part 1 - About Solaris
Solaris is for Enterprises
OpenSolaris is for Developers
VirtualBox allows Developers running Host Operating Systems (i.e. OpenSolaris, Mac, Linux, Windows, etc.) to run other operating systems (i.e. Solaris 10)
Demo of Import VirtualBox Solaris 10 2 Gigabyte Image into Virtual Box
Solaris 10 is mature, has been around since 2005, 8 releases
GNOME Interface demonstration - Part 2 - Where is Everything?
Important Directories
/usr/sbin - system administration commands
/usr/bin - normal user commands
/var - variable files (i.e. logs)
/etc - configuration files
/opt - third party software
/export/home - home directories for users
Add a user "dan"
machine# useradd -m -d /export/home/dan -s /usr/bin/ksh dan
Set the user password for "dan"
machine# passwd dan
****
****
Set the user password for "dan" where he is forced to change the user password on first login
machine# passwd -f dan
****
**** - Part 3 - Users
Rights Profiles
Adding System Administrator Commands to your path
machine# echo "PATH=$PATH:/usr/sbin export PATH" >>/etc/profile
machine# . /etc/profile
Running commands against the profile permissions available
machine# pfexec usermod -P "Primary Administrator" dan
Converting root from a user into a role which can only be assumed by a user
machine# pfexec usermod -K type=role root
machine# su - root
Adding the ability for a user (dan) to be allowed to assume the root role
machine# pfexec usermod -R root dan - Part 4 - Managing Software
Solaris SVR4 Packaging
pkgadd, pkginfo
-- UPDATE! -- 2010-05-15 -- More Videos to continue the introduction to Solaris!
- Part 5 - System Services
Solaris Service Management Facility (SMF)
- operates services like web servers
- provides for automatic restart of failed services
- give the ability for hierarchal relationships between services
Basic User Commands for checking status
Check for all running services
# svs | more
Check for all configured services (running and not running)
# svcs -a | more
Checked for failed services
# svcs -x
Check for impacted services to a failed service
# svcs -xv
Show the long version of the svc with the process id
# svcs -lp ssh
Basic Administration Command for changing status
Enable, Disable, or Restart Services
# svcadm enable [service]
# svcadm disable [service]
# svcadm restart [service] - Part 6 - Networking
Important Commands
View Physical Devices
# dladm show-dev
View Network Interfaces
# ifconfig -a
To change a Host Name with supporting Network information
# sys-unconfig
Important Network Files
Name Service Configuration File
/etc/nsswitch.conf
DNS Name Resolver Configuration File
/etc/resolv.conf
Static Host Configuration File
/etc/hosts - Part 7 - Devices Names and File Systems
Naming of a Devices
c#t#d#[s|p]#
- c=Controller
- t=Target (not used in IDE devices)
- d=Device
- s=Slice (not used in IDE)
- p=Partition (Intel has 4 primary partitions)
Identifying Devices
# format
File Systems
- UFS - Default file system
- ZFS - New file system
- NFS - Network File System
ZFS
- introduced in Update 6 (2008-10 or 10/08)
- can now use ZFS for root file system
- Using ZFS for root file system has performance benefit with LiveUpgrade via a snapshot!
- Migrating from USF to ZFS: http://docs.sun.com/app/docs/doc/819-541/ggpdm
NFS
Show mounts on a remote server
# showmount -e [server]
Mount a remote server
# cd /net/[server]
No comments:
Post a Comment